Vcard
Vcard est un mot de 5 lettres formé à partir du mot Vcar auquel on ajoute la lettre D.
Que signifie le mot Vcard ?
vCard est un format numérique d'échange de données personnelles (abréviation de l'anglais visit card soit « carte de visite »), ouvert et défini par les RFC 6350 et 6868 (2011, version 4.0). Ce format est utilisé par les logiciels Contacts d'Apple, Mozilla Thunderbird de Mozilla, ou Outlook Express de Microsoft. vCard est également utilisé par les appareils mobiles (smartphones, téléphones mobiles, assistants personnels, GPS), ainsi que par les logiciels de messagerie instantanée comme Jabber ou Skype.
Format
Le fichier vCard est un format de carnet d'adresses qui peut contenir une ou plusieurs adresses. Lorsqu'il n'en contient qu'une seule, on parle plus naturellement de carte de visite.
Un fichier vCard porte une extension vcf (sigle pour Virtual Card File). Son contenu est lisible par n'importe quel éditeur de texte.
Historique
Les différences entre les formats sont exposées en annexe de la RFC.
Exemples
L'exemple suivant est un fichier avec une adresse unique.
Exemples : Jean_Dupont.vcf
vCard 2.1 (1996) :
BEGIN:VCARD
VERSION:2.1
FN:Jean Dupont
N:Dupont;Jean
ADR;WORK;PREF;QUOTED-PRINTABLE:;Bruxelles 1200=Belgique;6A Rue Th. Decuyper
LABEL;QUOTED-PRINTABLE;WORK;PREF:Rue Th. Decuyper 6A=Bruxelles 1200=Belgique
TEL;CELL:+1234 56789
EMAIL;INTERNET:[email protected]
UID:
END:VCARD
vCard 3.0 (1998) :
BEGIN:VCARD
VERSION:3.0
N:Gump;Forrest
FN:Forrest Gump
ORG:Bubba Gump Shrimp Co.
TITLE:Shrimp Man
PHOTO;VALUE=URL;TYPE=GIF:http://www.example.com/dir_photos/my_photo.gif
TEL;TYPE=WORK;VOICE:(111) 555-1212
TEL;TYPE=HOME;VOICE:(404) 555-1212
ADR;TYPE=WORK:;;100 Waters Edge;Baytown;LA;30314;United States of America
LABEL;TYPE=WORK:100 Waters Edge\nBaytown, LA 30314\nUnited States of America
ADR;TYPE=HOME:;;42 Plantation St.;Baytown;LA;30314;United States of America
LABEL;TYPE=HOME:42 Plantation St.\nBaytown, LA 30314\nUnited States of America
EMAIL;TYPE=PREF,INTERNET:[email protected]
REV:20080424T195243Z
END:VCARD
vCard 4.0 (2011) :
BEGIN:VCARD
VERSION:4.0
N:Gump;Forrest;;Mr.;
FN:Forrest Gump
ORG:Bubba Gump Shrimp Co.
TITLE:Shrimp Man
PHOTO;MEDIATYPE=image/gif:http://www.example.com/dir_photos/my_photo.gif
TEL;TYPE=work,voice;VALUE=uri:tel:+1-111-555-1212
TEL;TYPE=home,voice;VALUE=uri:tel:+1-404-555-1212
ADR;TYPE=WORK;PREF=1;LABEL="100 Waters Edge\nBaytown\n, LA 30314\nUnited States of America":;;100 Waters Edge;Baytown;LA;30314;United States of America
ADR;TYPE=HOME;LABEL="42 Plantation St.\nBaytown\, LA 30314\nUnited States of America":;;42 Plantation St.;Baytown;LA;30314;United States of America
EMAIL:[email protected]
REV:20080424T195243Z
x-qq:21588891
END:VCARD
Un carnet d'adresses est constitué d'une suite de cartes commençant par BEGIN:VCARD et se terminant par END:VCARD.
Propriétés
Le format vCard utilise les types de propriétés suivants. Toute vCard commence par BEGIN:VCARD et se termine par END:VCARD. Toute vCard doit contenir la propriété VERSION, qui définit la version de la vCard. VERSION doit apparaître immédiatement après BEGIN, excepté dans le standard vCard 2.1 où elle peut apparaître n'importe où. Toutes les autres propriétés sont facultatives selon les versions et peuvent être définies dans n'importe quel ordre.
Voir aussi
iCalendar
Notes
Liens externes
(en) RFC 2425, obsolète
(en) RFC 2426, obsolète
(en) RFC 6350 (2011)
(fr) Exporter et Importer le Carnet d'adresses vCard d'un téléphone vers une autre application
(en) RFC 6350
Portail de l’informatique